Frequently Asked Questions

FAQ's » Error 2503 called runscript when not marked in progress and Error 2502

Error 2503 Called RunScript when not marked in progress and Error 2502 Called InstallFinalize when no install in progress.

Symptoms:

When attempting to install any software on Windows, Microsoft Installer MSI may display a message:

Error 2503 Called RunScript when not marked in progress

Error 2502 Called InstallFinalize when no install in progress

Cause:

This is a Microsoft Windows Installer error message (MSI is part of Windows OS) which just happens to get picked up during installation of a Windows based software, in this case Andica software. This is not caused by Andica Software.

The most likely causes for Windows to display this Windows message are:

  1. When the system date on your computer is set incorrectly.
  2. Windows User write permission issues: Windows has denied your Login User name access to certain Windows Installation folders and permission to perform certain tasks on the computer.

Solution:

Following suggestions may help resolve issues caused by each of the above numbered items:

  1. Reset the date on your computer to the correct date. To do this, follow these steps.
    NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
    1. Click Start, point to Settings, and then click Control Panel.
    2. In Control Panel, double-click Date and Time.
    3. In the Date and Time Properties dialog box, edit the information so that the current date and time are displayed.
    4. Click Apply, and then click OK.
    5. Restart Installation of the software.
  2. Check the write permissions of the installation directories such as:
    C:\Windows\Installer
    C:\Windows\Temp

    These may be hidden system folders.

    1. Open Windows Explorer
    2. Select Organize - Folder and search options - View tab
    3. Under 'Hidden files and Folders' select 'Show hidden files, folders, and drives'
    4. Right click on the folder and select 'Properties'
    5. Select 'Security' tab and amend permissions. The permissions required on the folder are as follows:
      SYSTEM - Full Control
      Administrators - Full Control

A System Engineer with knowledge of Windows OS may be able to suggest other configurations on the computer where the software is being installed.


Disclaimer: Information provided here is given without any obligations and we will not accept any claims or liabilities for any damages as a result of you relying on the information given here, if in doubt you must consult a qualified system engineer. Any web links provided to third party website are for your reference, we do not have any control on the validity and content on those websites. We do not take any responsibility for you using or relying on them. Copyright to contents remains with the owner of that website.

Top